using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)? - ([A-Z.])?\. ?([A-Z])?\. ([A-Za-z-']*)";
string substitution = @"\4, \2 \3 - \1";
string input = @"No Way Home - A. C. Crispin";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}