import Foundation
let pattern = #"^(.*)? - ([A-Z.])?\. ?([A-Z])?\. ([A-Za-z-']*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"No Way Home - A. C. Crispin"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\4, \2 \3 - \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)