#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*)? - ([A-Z.])?\. ?([A-Z])?\. ([A-Za-z-']*)"
Local $sString = "No Way Home - A. C. Crispin"
Local $sSubst = "\4, \2 \3 - \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)