$re = '/^(.*)? - ([A-Z.])?\. ?([A-Z])?\. ([A-Za-z-\']*)/m';
$str = 'No Way Home - A. C. Crispin';
$subst = "\4, \2 \3 - \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;