re = /^(.*)? - ([A-Z.])?\. ?([A-Z])?\. ([A-Za-z-']*)/m
str = 'No Way Home - A. C. Crispin'
subst = '\\4, \\2 \\3 - \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result