using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\r\n]{5})";
string substitution = @"$1\r\n";
string input = @" aaa
bbbbbbb
cc
dddddddddddd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}