import re
regex = re.compile(r"([^\r\n]{5})")
test_str = (" aaa\n"
"bbbbbbb\n"
"cc\n"
"dddddddddddd")
subst = "$1\\r\\n"
result = regex.sub(subst, test_str)
if result:
print(result)