use strict;
my $str = ' aaa
bbbbbbb
cc
dddddddddddd';
my $regex = qr/([^\r\n]{5})/p;
my $subst = '$1\\r\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";