const regex = /([^\r\n]{5})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\r\\n]{5})', 'g')
const str = ` aaa
bbbbbbb
cc
dddddddddddd`;
const subst = `$1\r\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);