re = /([^\r\n]{5})/
str = ' aaa
bbbbbbb
cc
dddddddddddd'
subst = '$1\\r\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result