import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\r\\n]{5})";
final String string = " aaa\n"
+ "bbbbbbb\n"
+ "cc\n"
+ "dddddddddddd";
final String subst = "$1\\r\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}