# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/=hyperlink\("([@\\\w\s\(\)\-\.\\/]+\\([^"]+))"\)/<a href="file:\/\/\/$1">$2<\/a>/gi;t' <<< "=hyperlink(\"\\share\folder\log\2013\13-05-13\13-05-13.txt\")"