#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)=hyperlink\("([@\\\w\s\(\)\-\.\/]+\\([^"]+))"\)"
Local $sString = "=hyperlink("\\share\folder\log\2013\13-05-13\13-05-13.txt")"
Local $sSubst = "<a href="file:///$1">$2</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)