package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)=hyperlink\("([@\\\w\s\(\)\-\.\/]+\\([^"]+))"\)`)
var str = `=hyperlink("\\share\folder\log\2013\13-05-13\13-05-13.txt")`
var substitution = "<a href="file:///$1">$2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}