// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)=hyperlink\("([@\\\w\s\(\)\-\.\/]+\\([^"]+))"\)"#).unwrap();
let string = "=hyperlink(\"\\\\share\\folder\\log\\2013\\13-05-13\\13-05-13.txt\")";
let substitution = "<a href=\"file:///$1\">$2</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}