import Foundation
let pattern = #"=hyperlink\("([@\\\w\s\(\)\-\.\/]+\\([^"]+))"\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"=hyperlink("\\share\folder\log\2013\13-05-13\13-05-13.txt")"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="file:///$1">$2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)