const regex = /=hyperlink\("([@\\\w\s\(\)\-\.\/]+\\([^"]+))"\)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=hyperlink\\("([@\\\\\\w\\s\\(\\)\\-\\.\\\/]+\\\\([^"]+))"\\)', 'gi')
const str = `=hyperlink("\\\\share\\folder\\log\\2013\\13-05-13\\13-05-13.txt")`;
const subst = `<a href="file:///$1">$2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);