re = /=hyperlink\("([@\\\w\s\(\)\-\.\/]+\\([^"]+))"\)/i
str = '=hyperlink("\\\\share\\folder\\log\\2013\\13-05-13\\13-05-13.txt")'
subst = '<a href="file:///$1">$2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result