import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "=hyperlink\\(\"([@\\\\\\w\\s\\(\\)\\-\\.\\/]+\\\\([^\"]+))\"\\)";
final String string = "=hyperlink(\"\\\\share\\folder\\log\\2013\\13-05-13\\13-05-13.txt\")";
final String subst = "<a href=\"file:///$1\">$2</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}