#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^ \w+%#()*+.,/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’'"-]"
Local $sString = "This is a text 莊子 that contains · forbidden characters."
Local $sSubst = "<span>$&</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)