// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"[^ \w+%#()*+.,/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’'"-]"#).unwrap();
let string = "This is a text 莊子 that contains · forbidden characters.";
let substitution = "<span>$&</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}