using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^ \w+%#()*+.,/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’'""-]";
string substitution = @"<span>$&</span>";
string input = @"This is a text 莊子 that contains · forbidden characters.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}