re = /[^ \w+%#()*+.,\/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’'"-]/
str = 'This is a text 莊子 that contains · forbidden characters.'
subst = '<span>$&</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result