import Foundation
let pattern = ##"[^ \w+%#()*+.,/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’'"-]"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is a text 莊子 that contains · forbidden characters."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span>$&</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)