package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^ \w+%#()*+.,/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’'"-]`)
var str = `This is a text 莊子 that contains · forbidden characters.`
var substitution = "<span>$&</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}