import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^ \\w+%#()*+.,/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’'\"-]";
final String string = "This is a text 莊子 that contains · forbidden characters.";
final String subst = "<span>$&</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}