const regex = /[^ \w+%#()*+.,/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’'"-]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^ \\w+%#()*+.,\/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’\'"-]', 'g')
const str = `This is a text 莊子 that contains · forbidden characters.`;
const subst = `<span>$&</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);