use strict;
my $str = 'This is a text 莊子 that contains · forbidden characters.';
my $regex = qr/[^ \w+%#()*+.,/:;<=>?€£¥§ÄÅÜäèéìñòöùü=“”‘’'"-]/p;
my $subst = '<span>$&</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";