# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([{,]\s*")app\.kubernetes\.io\\/([^"]+"\s*:)/$1app_kubernetes_io_$2/gm;t' <<< "{ \"kubernetes\": { \"labels\": { \"app.kubernetes.io/name\": \"name\", \"app.kubernetes.io/version\": \"1.2.3\", \"no-match-field\": \"app.kubernetes.io/name\" } } }"