const regex = /([{,]\s*")app\.kubernetes\.io\/([^"]+"\s*:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([{,]\\s*")app\\.kubernetes\\.io\\\/([^"]+"\\s*:)', 'gm')
const str = `{ "kubernetes": { "labels": { "app.kubernetes.io/name": "name", "app.kubernetes.io/version": "1.2.3", "no-match-field": "app.kubernetes.io/name" } } }`;
const subst = `$1app_kubernetes_io_$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);