package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([{,]\s*")app\.kubernetes\.io\/([^"]+"\s*:)`)
var str = `{ "kubernetes": { "labels": { "app.kubernetes.io/name": "name", "app.kubernetes.io/version": "1.2.3", "no-match-field": "app.kubernetes.io/name" } } }`
var substitution = "$1app_kubernetes_io_$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}