re = /([{,]\s*")app\.kubernetes\.io\/([^"]+"\s*:)/m
str = '{ "kubernetes": { "labels": { "app.kubernetes.io/name": "name", "app.kubernetes.io/version": "1.2.3", "no-match-field": "app.kubernetes.io/name" } } }'
subst = '$1app_kubernetes_io_$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result