// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([{,]\s*")app\.kubernetes\.io\/([^"]+"\s*:)"#).unwrap();
let string = "{ \"kubernetes\": { \"labels\": { \"app.kubernetes.io/name\": \"name\", \"app.kubernetes.io/version\": \"1.2.3\", \"no-match-field\": \"app.kubernetes.io/name\" } } }";
let substitution = "$1app_kubernetes_io_$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}