use strict;
my $str = '{ "kubernetes": { "labels": { "app.kubernetes.io/name": "name", "app.kubernetes.io/version": "1.2.3", "no-match-field": "app.kubernetes.io/name" } } }';
my $regex = qr/([{,]\s*")app\.kubernetes\.io\/([^"]+"\s*:)/mp;
my $subst = '$1app_kubernetes_io_$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";