$re = '/([{,]\s*")app\.kubernetes\.io\/([^"]+"\s*:)/m';
$str = '{ "kubernetes": { "labels": { "app.kubernetes.io/name": "name", "app.kubernetes.io/version": "1.2.3", "no-match-field": "app.kubernetes.io/name" } } }';
$subst = "$1app_kubernetes_io_$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;