import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\{,]\\s*\")app\\.kubernetes\\.io\\/([^\"]+\"\\s*:)";
final String string = "{ \"kubernetes\": { \"labels\": { \"app.kubernetes.io/name\": \"name\", \"app.kubernetes.io/version\": \"1.2.3\", \"no-match-field\": \"app.kubernetes.io/name\" } } }";
final String subst = "$1app_kubernetes_io_$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}