# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z])0( [a-z])/$1.$2/g;t' <<< "Eg.1 a0 p
Eg.2 p0 sa
Eg.3 ap0 l"