using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z])0( [a-z])";
string substitution = @"$1.$2";
string input = @"Eg.1 a0 p
Eg.2 p0 sa
Eg.3 ap0 l";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}