const regex = /([a-z])0( [a-z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z])0( [a-z])', 'g')
const str = `Eg.1 a0 p
Eg.2 p0 sa
Eg.3 ap0 l`;
const subst = `$1.$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);