re = /([a-z])0( [a-z])/
str = 'Eg.1 a0 p
Eg.2 p0 sa
Eg.3 ap0 l'
subst = '$1.$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result