import Foundation
let pattern = #"([a-z])0( [a-z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Eg.1 a0 p
Eg.2 p0 sa
Eg.3 ap0 l
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1.$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)