import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z])0( [a-z])";
final String string = "Eg.1 a0 p\n"
+ "Eg.2 p0 sa\n"
+ "Eg.3 ap0 l";
final String subst = "$1.$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}