#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([a-z])0( [a-z])"
Local $sString = "Eg.1 a0 p" & @CRLF & _
"Eg.2 p0 sa" & @CRLF & _
"Eg.3 ap0 l"
Local $sSubst = "$1.$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)