use strict;
my $str = 'Eg.1 a0 p
Eg.2 p0 sa
Eg.3 ap0 l';
my $regex = qr/([a-z])0( [a-z])/p;
my $subst = '$1.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";