package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[$]this->translate[(]'((?:[^'\\]|\\.|'')*)'[)];`)
var str = `$This->Translate('(?:Droids\');{2}');
$NotTranalate('fdasad');
$this->translate('[a-zA-Z]');
$this->translate('1_category_label');
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}