import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[$]this->translate[(]'((?:[^'\\\\]|\\\\.|'')*)'[)];";
final String string = "$This->Translate('(?:Droids\\');{2}');\n"
+ "$NotTranalate('fdasad');\n"
+ "$this->translate('[a-zA-Z]');\n"
+ "$this->translate('1_category_label');\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}