re = /[$]this->translate[(]'((?:[^'\\]|\\.|'')*)'[)];/mix
str = '$This->Translate(\'(?:Droids\\\');{2}\');
$NotTranalate(\'fdasad\');
$this->translate(\'[a-zA-Z]\');
$this->translate(\'1_category_label\');
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result