use strict;
my $str = '$This->Translate(\'(?:Droids\\\');{2}\');
$NotTranalate(\'fdasad\');
$this->translate(\'[a-zA-Z]\');
$this->translate(\'1_category_label\');
';
my $regex = qr/[$]this->translate[(]'((?:[^'\\]|\\.|'')*)'[)];/mixp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";