const regex = /[$]this->translate[(]'((?:[^'\\]|\\.|'')*)'[)];/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[$]this->translate[(]\'((?:[^\'\\\\]|\\\\.|\'\')*)\'[)];', 'gmi')
const str = `\$This->Translate('(?:Droids\\');{2}');
\$NotTranalate('fdasad');
\$this->translate('[a-zA-Z]');
\$this->translate('1_category_label');
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);