// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mix)[$]this->translate[(]'((?:[^'\\]|\\.|'')*)'[)];").unwrap();
let string = "$This->Translate('(?:Droids\\');{2}');
$NotTranalate('fdasad');
$this->translate('[a-zA-Z]');
$this->translate('1_category_label');
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}